O melhor pedaço da Maçã.
MM News

Receba os nossos principais artigos diariamente, por email.

Ironia: donos de iPhones e iPods touch antigos estão mais seguros *com* jailbreak [atualizado]

PDF Loading Warner no Cydia

Veja só, que curioso: ontem no final do dia a Apple lançou o iOS 4.0.2 para iPhones/iPods touch, porém ele evidentemente não é compatível com iPhones 2G e iPods touch de primeira geração. Usuários destes ainda estão “presos” no firmware 3.1.3 — com a tal vulnerabilidade de PDF aberta para o mundo.

Publicidade

Pode ser que a Apple não tenha priorizado uma atualização 3.1.4 da vida e que ela chegue daqui a alguns dias/semanas, mas isso não é certo. Portanto, a grande ironia é que donos de iPhones/iPods touch antigos *devem* fazer jailbreak em seus aparelhos se quiserem ficar seguros quanto a essa vulnerabilidade, usando do mesmo artifício que tínhamos noticiado há alguns dias.

PDF Loading Warner no Cydia

O hacker Jay “saurik” Freeman já trabalha numa outra solução semelhante à que você vê acima, que será capaz de fechar a brecha de PDF em qualquer iPhone/iPod touch rodando desde o firmware 2.2 até o 4.0.1. O software ainda está em fase de testes, mas deverá ser liberado para todos logo, logo.

Publicidade

Quem diria, hein Apple? Hackers fazendo o que você não faz… Será que já é hora mesmo de abandonar usuários desses gadgets mais antigos? :-/

[via Dev-Team Blog]

Atualização

A solução de “saurik” — chamada PDF Patch — já foi disponibilizada para download. Feedbacks são bem-vindos.

Ver comentários do post

Carregando os comentários…
Artigo Anterior
iPod shuffle com multi-touch

Mockup antigo mostra como seria um iPod shuffle com tela multi-touch

Próximo Artigo
Ícone do Game Center

Apple permite que desenvolvedores comecem a configurar o Game Center em seus aplicativos

Posts Relacionados